Zend Optimizer not installed

Magic SEO URLs for Zen Cart.
abhishek77
Posts: 5
Joined: Mon Feb 09, 2009 12:59 pm

Zend Optimizer not installed

Postby abhishek77 » Mon Feb 09, 2009 1:09 pm

I am not sure what to do from step 6 onwards of the install.html file.

6. Setup access rights for the file www/.htaccess to 666 (rights for read and write by user, group and other users).
7. Display at least once main page of your eshop (the content of www/.htaccess file will be generated).
8. Change access rights of www/.htaccess file back (probably to 444 - rights for read by user, read only for group and other users).
If you are unable to make www/.htaccess file read only for PHP scripts, create new blank file readonly-htaccess in same directory. This step can not be omitted!
9. The installation or update is finished.


The .htaccess file is hidden when i access the server via ftp.
Nest step is that it asks for main page to be displayed of the eshop, is this the homepage or individual product page?

Finally I am getting this message on screen.

Zend Optimizer not installed
This file was encoded by the Zend Guard. In order to run it, please install the Zend Optimizer (available without charge), version 3.0.0 or later. ................

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: Zend Optimizer not installed

Postby inveo » Mon Feb 09, 2009 1:22 pm

abhishek77 wrote:The .htaccess file is hidden when i access the server via ftp.
Nest step is that it asks for main page to be displayed of the eshop, is this the homepage or individual product page?


It can be any store page.

abhishek77 wrote:Finally I am getting this message on screen.


Your web server is missing Zend Optimizer. Please ask your host for its installation.

abhishek77
Posts: 5
Joined: Mon Feb 09, 2009 12:59 pm

Re: Zend Optimizer not installed

Postby abhishek77 » Mon Feb 09, 2009 5:25 pm

I am not sure abt the Zend Optimizer issue but i will enquire about it tomorrow now.
The site was however working before i had made the changes contained with install.html

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: Zend Optimizer not installed

Postby inveo » Mon Feb 09, 2009 6:15 pm

If you comment out installation line in includes/application_top.php your site will be back.

What is your host?

abhishek77
Posts: 5
Joined: Mon Feb 09, 2009 12:59 pm

Re: Zend Optimizer not installed

Postby abhishek77 » Tue Feb 10, 2009 5:23 pm

do you mean that i need to comment out this line:

Code: Select all

include(DIR_WS_INCLUDES . 'magic_seo_url.php');
?

If i comment out that line or even remove it, the site does come back but how do i go about installing this?

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: Zend Optimizer not installed

Postby inveo » Tue Feb 10, 2009 5:26 pm

Try to remove .htaccess file you have copied, but if the web server is configured correctly, it is not necessary. Also make sure you didn't make any typo when you were removing installation line (you see only blank page because error reporting is likely turned of on your web hosting).

abhishek77
Posts: 5
Joined: Mon Feb 09, 2009 12:59 pm

Re: Zend Optimizer not installed

Postby abhishek77 » Wed Feb 11, 2009 10:48 am

The issue is that I am getting the message "Zend Optimizer not installed" on my website.

When i remove the installaition line from within includes/application_top.php the site does come back.

I am not seeing any blank page.

What could be the cause for this and how do i sort this out?

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: Zend Optimizer not installed

Postby inveo » Wed Feb 11, 2009 10:49 am

I am now confused what is happening. Could you please post here your web site URL?

abhishek77
Posts: 5
Joined: Mon Feb 09, 2009 12:59 pm

Re: Zend Optimizer not installed

Postby abhishek77 » Wed Feb 11, 2009 12:36 pm

website URL is 976evil.com

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: Zend Optimizer not installed

Postby inveo » Wed Feb 11, 2009 1:11 pm

Your web server is missing Zend Optimizer. Please ask your host for its installation.