[Zen Cart] Test Site on Xampp - Not Working

Magic SEO URLs for Zen Cart.
cowspotbeads
Posts: 10
Joined: Tue Jun 10, 2008 6:01 pm

[Zen Cart] Test Site on Xampp - Not Working

Postby cowspotbeads » Sun Jun 22, 2008 6:10 pm

Hello,
I have a test site at home running the latest xampp. I copy my live site to my home computer and then run it. This way I can test new mods.

Since Magic Seo was installed on my live site, I have not been able to get my home test site running. I installed ZendOptimizer, and made any changes as required by the MSU install. I used the .htaccess and readonly-htaccess files from my live site. I received a CGI Script error.

I removed the readonly-htaccess file as I saw in another post and that did nothing. I removed all the information from the .htaccess in hopes of generating a new one hoping that was the issue. Now I just get a blank window.

If I disable the MSU in the application_top.php it seems the site works fine. Enable it and I get a blank page. Not sure if I am doing it right (regenerating the .htaccess file) or if that is even the issue.

Any ideas? I need to get it running so I can test a custom mod being written for my store.

Thanks in advance!
Cowspot
http://www.cowspotbeads.com

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Test Site on Xampp - Not Working

Postby inveo » Mon Jun 23, 2008 3:23 am

Magic SEO URL works only on enabled URLs. Using it on URL which was not enabled results in "do nothing" (but not in blank page - it is caused by different thing, turn on debugging and you will see error message instead of blank page).

MSU can be enabled for unlimited public accessible test web sites, but since MSU is not MOD (does not affect ZC API like ZC MODs do) testing it has no sense.

cowspotbeads
Posts: 10
Joined: Tue Jun 10, 2008 6:01 pm

Re: [Zen Cart] Test Site on Xampp - Not Working

Postby cowspotbeads » Mon Jun 23, 2008 10:47 am

Hi,

Thanks for the reply. I guess I will have to disable MSU on my test site, test any new mods I want to apply to my live site and hope that the mod does not affect MSU on my live site.

That is too bad that I can not get it working on my xampp local test site. I just want to make sure I do not break MSU on my live site.

marty
Posts: 1
Joined: Sat Jul 26, 2008 8:36 am

Re: [Zen Cart] Test Site on Xampp - Not Working

Postby marty » Sat Jul 26, 2008 8:50 am

Hello - I just purchased the CRELoaded version, I'm ashamed that I didn't read this thread before making my purchase.

It would be nice if the SEO tool could be used for the intended URL and at least test site, for instance: http://www.mystore.com/ and http://localhost/ or http://www.mystore.com/ and http://test.mystore.com/.

We are doing a re-design and will not be going live for approximately a month from now. Are you telling me that I just purchased the Magic SEO URL and have absolutely no way to make sure it works before that day?

I tried setting all my local machine settings, hosts file, xampp, and CRELoaded config files to point to my local machine as if it were the actual domain it is going to be running on live and it does not work. Also, we have a staging server at the new hosting provider and all the settings have been modified for that as well but does not work.

I cannot wait until launch day to find out whether or not this works as expected.

Please, any suggestions?

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Test Site on Xampp - Not Working

Postby inveo » Sat Jul 26, 2008 9:54 am

No problem. Magic SEO URL can be also enabled for unlimited number of public accessible test web sites. Just email/PM me URLs you want to enable and you receive updated package.