[Zen Cart] Server Switch - Category Problem

Magic SEO URLs for Zen Cart.
lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

[Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 8:06 am

Hey J,
My host recently upgraded their server and switched me to it (sounds like I have the same host as some others on here.)

Ever since the switch my website loads but 4 categories out of 20 or so, only load a blank page. I can't find any obvious errors so I'm wondering if it is possibly related to Magic SEO.

Thanks,
lindasdd

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Server Switch - Category Problem

Postby inveo » Sun May 31, 2009 8:15 am

Your host is likely running on IIS with ISAPI Rewrite installed, which has serious troubles with some Rewrite Rules for 4 category depth (it was reported to the authors and confirmed, but does not fixed up to now).
I hardly recommend to use IIS Mod-Rewrite with MS IIS web server.

lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

Re: [Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 8:35 am

Actually when I said 4 out of 20, I wasn't referring to depth of category. All of my categories have only 1 category of depth.

This problem is actually one where 4 of the 1st level categories don't load. I will PM you the site just in case that wasn't clear.

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Server Switch - Category Problem

Postby inveo » Sun May 31, 2009 8:39 am

It looks like as a Zen Cart problem (ZC script die expectedly before complete page is processed). I recommend you to temporary disable MSU (please see docs how to do it) and check what error message you receive. Once you correct it, you can enable MSU again.

lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

Re: [Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 8:42 am

When you say the 'docs' do you mean the docs folder of the Magic install I have.

The docs folder only has "Installation and update"

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Server Switch - Category Problem

Postby inveo » Sun May 31, 2009 8:47 am

I mean the docs folder in the installation package. To disable MSU, simply comment out installation line in includes/application_top.php file.

lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

Re: [Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 8:52 am

I removed MSU and now the category pages are loading ok.

So.....how do we figure out what portion of MSU related to the pages needs to be adjusted to fix,etc.

lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

Re: [Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 8:57 am

I'm assuming I should just do teh whole htaccess thing again, but I'm worried that will change all my category links which will give me a lot of dead links in other places.

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Server Switch - Category Problem

Postby inveo » Sun May 31, 2009 9:00 am

If all pages are now loading correctly, please contact your host. There is something wrong with PHP installation on upgraded server.

lindasdd
Posts: 14
Joined: Thu Mar 13, 2008 8:17 pm

Re: [Zen Cart] Server Switch - Category Problem

Postby lindasdd » Sun May 31, 2009 9:03 am

J,
You realize if I say that to them they aren't going to take it seriously.

Can you possibly provide a quick reason for why that would be the case based on what has happened here?

Thanks,
lindasdd