[Zen Cart] Not sure its working properly.

Magic SEO URLs for Zen Cart.
woodsrr
Posts: 1
Joined: Tue Feb 09, 2010 9:28 am

[Zen Cart] Not sure its working properly.

Postby woodsrr » Tue Feb 09, 2010 10:48 am

Magic SEO URL, Not sure its working properly.

I was handed this project mid stream so I'm not sure if this is working correctly. We have Zen Cart and have tried to load Magic SEO. Everything is up and running and we are getting friendly URL for the groups and sub-groups such as:

http://www.sitename.com/therapy/new-products-1138/aromatherapy-1337/

The problems is that when I click on a product I still get the url with parameters such as:
http://www.sitename.com/therapy/index.php?main_page=index&cPath=1138_1337&products_id=2096&sort=20a&page=1

Did we do something wrong or do we not get a friendly url with the product as we do with the groups and sub-groups?

Thanks for any help...

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Not sure its working properly.

Postby inveo » Tue Feb 09, 2010 11:25 am

URIs you are using for products are not correct Zen Cart URIs and therefore are not transformed to SEO format.

It should be:

index.php?main_page=product_info&products_id=20
or
index.php?main_page=product_info&cPath=1138_1337&products_id=20

instead of:

index.php?main_page=index&cPath=1138_1337&products_id=2096&sort=20a&page=1

(&sort=20a and &page=1 are obsolete parameters, main_page should hold product handler such as product_info etc.)