[Zen Cart] Connection interrupted (HTTPS)

Magic SEO URLs for Zen Cart.
gercabace
Posts: 3
Joined: Mon Feb 18, 2008 1:30 am

[Zen Cart] Connection interrupted (HTTPS)

Postby gercabace » Mon Feb 18, 2008 2:45 am

I have had to disable MSU on my shop because I get errors on searching products, login/logoff operations.
When I try searching product:

-> On Firefox, I get the error message (translated from spanish):
The connection was interrupted.
The connection to http://www.regaprichos.com was interrupted while the page it was loaded.

and the URL showed is:
"https://www.regaprichos.com/search/results.html?search_in_description=1&zenid=c27f1724efb9626fa1e60b7f8450debd&keyword=nabaztag"
Note: I do not use SSL on my shop. I have set on both confgure.php files "define('ENABLE_SSL', 'false');"

-> on IExplorer, I get the error message (translated from spanish):
Is not possible to show the page
and the URL showed is different that the showed one for FF:
http://www.regaprichos.com/search/resul ... d=nabaztag

Some ideas?

Thanks
www.RegaPrichos.com

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [ZenCart] Connection interrupted on searching product

Postby inveo » Mon Feb 18, 2008 3:19 am

It looks like you web server is configured incorrectly and is returning bad request type. Try to place following code to the application_top.php before installation line:

Code: Select all

$_SERVER['HTTPS'] = 'off';

gercabace
Posts: 3
Joined: Mon Feb 18, 2008 1:30 am

Re: [ZenCart] Connection interrupted on searching product

Postby gercabace » Mon Feb 18, 2008 3:33 am

I have done the modification and the error persists.
I leave MSU enabled in order to you can test it.
www.RegaPrichos.com

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [ZenCart] Connection interrupted on searching product

Postby inveo » Mon Feb 18, 2008 3:37 am

It was bad suggestion from me previously. The code should looks like this:

Code: Select all

putenv('HTTPS=off');

gercabace
Posts: 3
Joined: Mon Feb 18, 2008 1:30 am

Re: [ZenCart] Connection interrupted on searching product

Postby gercabace » Mon Feb 18, 2008 3:47 am

Great! - It is working!
I am going to continue testing but it seems that everything works OK.
Do you believe that I should warn to my hosting people about this?
Thank you very much.
www.RegaPrichos.com

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [ZenCart] Connection interrupted on searching product

Postby inveo » Mon Feb 18, 2008 3:52 am

gercabace wrote:Do you believe that I should warn to my hosting people about this?

Yes, it is good idea, because following code:

Code: Select all

getenv('HTTPS');

is returning 'on' even if HTTPS is not used...