[Zen Cart] Changed index after install SEO mod

Magic SEO URLs for Zen Cart.
Niking
Posts: 7
Joined: Sun Apr 03, 2011 10:39 pm

[Zen Cart] Changed index after install SEO mod

Postby Niking » Tue Mar 12, 2013 8:15 pm

Hi Magic Seo URLS,

I have a heavily modified home page, but after install the SEO mod, all other page works great except the home page, my customized home page is missing , but instead the home page turns to be the "stock home page". Any idea where the problem is?

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Changed index after install SEO mod

Postby inveo » Wed Mar 13, 2013 10:16 am

Please post what store are you using,Magic SEO URLs version or at least your web site URL.

Niking
Posts: 7
Joined: Sun Apr 03, 2011 10:39 pm

Re: [Zen Cart] Changed index after install SEO mod

Postby Niking » Wed Mar 13, 2013 8:16 pm

Sorry, my bad.
I'll keep my site still with the Mod on.

The Shopping Cart is: Zen Cart 1.3.9h
My Magic SEO URLs Version is: v3

My site is: http://www.mushtato.com.au/

Thanks for your help. :P

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Changed index after install SEO mod

Postby inveo » Thu Mar 14, 2013 10:43 am

Please PM me your FTP credentials. I know where is the problem but can not provide you with solution until I see it.

Niking
Posts: 7
Joined: Sun Apr 03, 2011 10:39 pm

Re: [Zen Cart] Changed index after install SEO mod

Postby Niking » Thu Mar 14, 2013 8:58 pm

Thank you for your great service and great product.
I'll definitely recommend your product to my friends.

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Changed index after install SEO mod

Postby inveo » Fri Mar 15, 2013 11:11 am

It is re-solved now.

We had to change in /index.php file

Code: Select all

$noindex = empty($_SERVER['QUERY_STRING']) ? 0 : 1;


to

Code: Select all

$noindex = ($_SERVER['REQUEST_URI'] == '/') ? false : true;


and add

Code: Select all

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER . DIR_WS_HTTPS_CATALOG : HTTP_SERVER . DIR_WS_CATALOG ); ?>" />


to /includes/templates/template_default/common/tpl_index_page.php file.

MSU Sitemaps are at http://mushtato.com.au/sitemaps.php

Niking
Posts: 7
Joined: Sun Apr 03, 2011 10:39 pm

Re: [Zen Cart] Changed index after install SEO mod

Postby Niking » Mon Apr 15, 2013 2:54 am

Hi ~j~,

I have another question. After modified the mentioned file, the tpl_index_page.php works well.
But I think there still a problem in the rewrite file .htaccess
When I input my domain http://www.mushtato.com.au/ it always redirected to the "http://mushtato.com.au/" , so do you know how to fix this problem?

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Changed index after install SEO mod

Postby inveo » Mon Apr 15, 2013 4:44 am

It redirects to http://mushtato.com.au/ because you've activate your MSU for this location (to avoid duplicate content with http://www.mushtato.com.au/).

Niking
Posts: 7
Joined: Sun Apr 03, 2011 10:39 pm

Re: [Zen Cart] Changed index after install SEO mod

Postby Niking » Mon Apr 15, 2013 8:45 pm

Thanks for your answer. But is there any way I can use www.mushtato.com.au as the default one?

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Changed index after install SEO mod

Postby inveo » Tue Apr 16, 2013 5:05 am

Yes of course. You need to re-configure your Zen Cart to www.mushtato.com.au and then re-activate your MSU for this location.