[Zen Cart] Blank Page with www.domain - Ok with domain

Magic SEO URLs for Zen Cart.
JRayfield
Posts: 12
Joined: Mon Dec 28, 2009 1:56 pm

[Zen Cart] Blank Page with www.domain - Ok with domain

Postby JRayfield » Tue Jan 19, 2010 1:15 pm

I installed Magic SEO URL and it does indeed work, but only if I use the domain without the 'www'. So, http://rayfield.net works fine, but http://www.rayfield.net does not work - I only get a blank page.

I inserted the error-reporting lines and got this:

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home/rayfield/public_html/includes/languages/241/english.php:1375) in /home/rayfield/public_html/includes/magic_seo_url.php on line 0

Warning: Cannot modify header information - headers already sent by (output started at /home/rayfield/public_html/includes/languages/241/english.php:1375) in /home/rayfield/public_html/includes/magic_seo_url.php on line 0

Notice: Object of class queryFactoryResult could not be converted to int in Unknown on line 0


I've removed Magic SEO URL and everything works fine again (of course, without the 'pretty' URLs).

Any suggestions on how to fix this?

John Rayfield, Jr.
http://www.rayfield.net

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Car] Blank Page with www.domain - Ok with domain

Postby inveo » Tue Jan 19, 2010 1:27 pm

I guess there are some white characters at the bottom of /home/rayfield/public_html/includes/languages/241/english.php file after ?> (and for that reason redirection fails).

JRayfield
Posts: 12
Joined: Mon Dec 28, 2009 1:56 pm

Re: [Zen Cart] Blank Page with www.domain - Ok with domain

Postby JRayfield » Tue Jan 19, 2010 2:56 pm

Yes, that was it! Thanks.

You might want to add this to your troubleshooting section of the installation documentation. I've seen that extra 'blank' line on other files in Zen-Cart, too.

John

JRayfield
Posts: 12
Joined: Mon Dec 28, 2009 1:56 pm

Re: [Zen Cart] Blank Page with www.domain - Ok with domain

Postby JRayfield » Mon Mar 01, 2010 1:52 pm

I've got the same problem that I had - rayfield.net works, but www.rayfield.net does not work.

I checked the english.php file for that 'white space', but it's fine.

Where else should I look for a solution?

John

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Blank Page with www.domain - Ok with domain

Postby inveo » Mon Mar 01, 2010 1:55 pm

Please see the Troubleshooting section in manual where you will find how to debug white/blank page.

JRayfield
Posts: 12
Joined: Mon Dec 28, 2009 1:56 pm

Re: [Zen Cart] Blank Page with www.domain - Ok with domain

Postby JRayfield » Mon Mar 01, 2010 1:59 pm

I found it. It was the meta_tags.php file.

John