[Zen Cart] Blank page after server change

Magic SEO URLs for Zen Cart.
SOSPCSHOP
Follower
Posts: 25
Joined: Sat May 16, 2009 10:43 am

[Zen Cart] Blank page after server change

Postby SOSPCSHOP » Thu Jan 17, 2013 1:57 pm

hi

I have moved my site to another server and now I see a blank page

I have add those lines

@ini_set('display_errors', '1');
error_reporting(E_ALL);

and now I read the message

Code: Select all

Fatal error: Cannot redeclare class InveoLoader in /web/htdocs/www.sospcshop.com/home/includes/magic_seo_url.php on line 16


I have reinstalled MSU, regenerated .htaccess ...
but do not understand what happened..

can you help me ?

thank you.
Salvo

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Blank page after server change

Postby inveo » Thu Jan 17, 2013 2:10 pm

It seems there are two Magic SEO URLs installation lines placed in includes/application_top.php file. Please double check this file.

SOSPCSHOP
Follower
Posts: 25
Joined: Sat May 16, 2009 10:43 am

Re: [Zen Cart] Blank page after server change

Postby SOSPCSHOP » Thu Jan 17, 2013 2:27 pm

Oh,
it is true... sorry! ...

I have wrote ...

Code: Select all

include(DIR_WS_INCLUDES . 'magic_seo_url.php');
if(!in_array(basename($_SERVER['SCRIPT_NAME']), array('datafeed_shopmania_zencart.php'))) include(DIR_WS_INCLUDES . 'magic_seo_url.php');

pardon !
ok now no error ...
but... msu do not works ...

I see the original url of zencart and at bottom I do not see the msu Copyright notice ..

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Blank page after server change

Postby inveo » Thu Jan 17, 2013 2:49 pm

Please re-activate at http://www.sospcshop.com/?inveoActivation

SOSPCSHOP
Follower
Posts: 25
Joined: Sat May 16, 2009 10:43 am

Re: [Zen Cart] Blank page after server change

Postby SOSPCSHOP » Thu Jan 17, 2013 2:57 pm

Ok, done ...
the url is ok
but.. now I see

404 page not found ..




ps. Many thanks for quick support !

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Blank page after server change

Postby inveo » Thu Jan 17, 2013 3:10 pm

You need to re-generate the .htaccess file, I would suggest to carry-out the complete installation process.

SOSPCSHOP
Follower
Posts: 25
Joined: Sat May 16, 2009 10:43 am

Re: [Zen Cart] Blank page after server change

Postby SOSPCSHOP » Thu Jan 17, 2013 3:23 pm

Hi I have found the problem of page not found...

the mod_rewrite was not enabled on server... present but not enabled..

many thanks for your help !

bye!

salvo

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Blank page after server change

Postby inveo » Thu Jan 17, 2013 4:35 pm

We are glad we could help you.