[Zen Cart] Apache Error Logs

Magic SEO URLs for Zen Cart.
Stuff4Toys
Posts: 8
Joined: Wed Aug 27, 2008 12:49 pm
Location: Wisconsin, USA
Contact:

[Zen Cart] Apache Error Logs

Postby Stuff4Toys » Tue Jan 13, 2009 1:49 pm

http://www.liberty-flag.com/
Zen-Cart 1.3.7
PHP5.2.8 w/Zen Optimizer installed on Linux Apache 2.2.11

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

My Apache error logs are full of this kind or error, and it's right there is no 404.shtml file on the server, but why is it not able to find these folders? The folders are there and the links all point to the correct categories!

[Tue Jan 13 14:29:04 2009] [error] [client 74.6.18.251] File does not exist: /home/liberty/public_html/404.shtml
[Tue Jan 13 14:29:04 2009] [error] [client 74.6.18.251] File does not exist: /home/liberty/public_html/state-territory-flags-3
[Tue Jan 13 14:29:03 2009] [error] [client 74.6.18.251] File does not exist: /home/liberty/public_html/404.shtml
[Tue Jan 13 14:29:03 2009] [error] [client 74.6.18.251] File does not exist: /home/liberty/public_html/state-territory-flags-3
[Tue Jan 13 14:25:54 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/404.shtml
[Tue Jan 13 14:25:54 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/nautical-marine-flags-154
[Tue Jan 13 14:25:54 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/404.shtml
[Tue Jan 13 14:25:54 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/nautical-marine-flags-154
[Tue Jan 13 14:25:51 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/404.shtml
[Tue Jan 13 14:25:51 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/nautical-marine-flags-154
[Tue Jan 13 14:23:58 2009] [error] [client 66.249.67.216] File does not exist: /home/liberty/public_html/404.shtml

What should a proper 404.shtml file look like? Do you have an example and what will happen if I add one? Will Magic SEO continue to work?

JOhn ><>
JM Kerusso - Quality Kerusso Christian Wear
Stuff4Toys - Stuff to make your boat Go Faster, Look Better and Last Longer

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Apache Error Logs

Postby inveo » Tue Jan 13, 2009 1:56 pm

Such error messages are not caused by MSU. To get rid of this message you can safely add 404.shtml file and MSU will work fine.

Stuff4Toys
Posts: 8
Joined: Wed Aug 27, 2008 12:49 pm
Location: Wisconsin, USA
Contact:

Re: [Zen Cart] Apache Error Logs

Postby Stuff4Toys » Tue Jan 13, 2009 2:03 pm

Why am I getting these entries?

[Tue Jan 13 14:25:51 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/nautical-marine-flags-154

The folder/path does exist.

Question??? when we first purchased MSU we were hosting on GoDaddy's servers and now we have moved to a dedicated server with a different physical path.

Does that make a difference in MSU?
JOhn ><>
JM Kerusso - Quality Kerusso Christian Wear
Stuff4Toys - Stuff to make your boat Go Faster, Look Better and Last Longer

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Apache Error Logs

Postby inveo » Tue Jan 13, 2009 3:05 pm

Stuff4Toys wrote:Why am I getting these entries?

[Tue Jan 13 14:25:51 2009] [error] [client 24.239.59.7] File does not exist: /home/liberty/public_html/nautical-marine-flags-154

The folder/path does exist.


GoDaddy's servers are well configured but most of dedicated not.


Stuff4Toys wrote:when we first purchased MSU we were hosting on GoDaddy's servers and now we have moved to a dedicated server with a different physical path.

Does that make a difference in MSU?


No.

What is your web site URL?

Stuff4Toys
Posts: 8
Joined: Wed Aug 27, 2008 12:49 pm
Location: Wisconsin, USA
Contact:

Re: [Zen Cart] Apache Error Logs

Postby Stuff4Toys » Tue Jan 13, 2009 3:34 pm

JM Kerusso - Quality Kerusso Christian Wear
Stuff4Toys - Stuff to make your boat Go Faster, Look Better and Last Longer

Stuff4Toys
Posts: 8
Joined: Wed Aug 27, 2008 12:49 pm
Location: Wisconsin, USA
Contact:

Re: [Zen Cart] Apache Error Logs

Postby Stuff4Toys » Tue Jan 13, 2009 3:37 pm

What will happen if I edit the .htaccess and add:
ErrorDocument 404 home/liberty/public/404.shtml
or
ErrorDocument 404 home/liberty/public/page_not_found.php

Will your program re-write and remove my additions?
JOhn ><>
JM Kerusso - Quality Kerusso Christian Wear
Stuff4Toys - Stuff to make your boat Go Faster, Look Better and Last Longer

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Apache Error Logs

Postby inveo » Tue Jan 13, 2009 3:44 pm

If you make .htaccess file read only or place readonly-htaccess file to the same directory, your changes remain.

BlessIsaacola
Follower
Posts: 98
Joined: Sun Feb 03, 2008 9:48 pm
Location: Kennesaw, GA
Contact:

Re: [Zen Cart] Apache Error Logs

Postby BlessIsaacola » Tue Feb 17, 2009 10:50 am

J-

I am moving the problem you're helping with to the forum as suggested in your email signature.

Here is the problem description for others:

I have pasted two errors below for you:
---------------------------------------------------------------------------------------------------------------
[Mon Feb 16 14:28:01 2009] [error] [client 71.*.*.*] File does not exist: /public_html/gift-and-home-5, referer: http://www.clevershoppers.com/gift-and- ... 66298.html

[Mon Feb 16 14:25:00 2009] [error] [client 68.*.*.*] File does not exist: /public_html/software-10, referer: http://www.clevershoppers.com/software- ... -4304.html

Basically what's happening is if you go http://www.clevershoppers.com/software- ... -4304.html for some reason, although you get to the right page, internally an error is generated that seems like instead of looking for /public_html/software-10/ it's looking for /public_html/software-10
-----------------------------------------------------------------------------------------------------------------

Well, we've done what you suggested and the host actually recompiled the server and the problem is still there. We did however noticed two things:

1. The error only happens for user accessing the site with IE and it happens whether it's IE 6.0, 7.0, 8.0. We were not able to duplicate the problem using 4 other browsers.

2. If I disable MSU in application_top.php EVERYTHING works flawlessly including using IE browsers and I am not able to duplicate the problem.

To me it sounds like there is something that doesn't play well with IE. I do not have any code in my.htaccess file, so if something is wrong there, that would have to be because it was generated wrong.

Please let me know what I can do from here...

To others reading this, can you please check your error log to see if you're experiencing similar issues?

Thanks!
http://www.clevershoppers.com - Where Clever People Shop!

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [Zen Cart] Apache Error Logs

Postby inveo » Tue Feb 17, 2009 11:59 am

I think it is simple. For some reasons, IE is trying to load /public_html/gift-and-home-5 (http://www.clevershoppers.com/gift-and-home-5). That's all. (it may be some pre-caching etc.)

BlessIsaacola
Follower
Posts: 98
Joined: Sun Feb 03, 2008 9:48 pm
Location: Kennesaw, GA
Contact:

Re: [Zen Cart] Apache Error Logs

Postby BlessIsaacola » Tue Feb 17, 2009 12:31 pm

Well, it's obviously not that simple if it's generating error in the log. Unfortunately, this behavior only happens when MSU is enabled. I also installed another SEO program just to test if the problem is the server (even though, I've been able to rule out server configuration), IE or MSU. I cannot say if this is MSU problem or not or if this is IE problem or not but I know the two are having issues playing together (to some degree). The other SEO I tested did not generate the same error in the log (so I am left think that MSU must have a part in this).

IF disabling MSU and installing a different SEO does not produce the same error, it would be logical to think the common denominator in this issue is now isolated to MSU.

I just emailed one of my friend who is also using MSU to check his log to see if the same problem is happening. I will report back shortly.
http://www.clevershoppers.com - Where Clever People Shop!