[PrestaShop Theme Provider] PS version compliancy

PrestaShop Modules including WordPress & phpBB Integration.
smachine
Posts: 2
Joined: Wed Apr 29, 2015 7:36 am

[PrestaShop Theme Provider] PS version compliancy

Postby smachine » Wed Apr 29, 2015 9:32 am

Hi there

Problem when trying to install the psthemeprovider Module for Prestashop

this is the error message

Code: Select all

- psthemeprovider :
The version of your module is not compliant with your PrestaShop version.


Prestashop version is 1.5.6

Need some help or advice.

Thank you

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [PrestaShop Theme Provider] PS version compliancy

Postby inveo » Wed Apr 29, 2015 9:38 am

Please post the value of "_PS_VERSION_" constant which is located in config/settings.inc.php file (should be '1.5.6.0' in your case).

smachine
Posts: 2
Joined: Wed Apr 29, 2015 7:36 am

Re: [PrestaShop Theme Provider] PS version compliancy

Postby smachine » Wed Apr 29, 2015 9:48 am

Yes your right

Code: Select all

define('_PS_VERSION_', '1.5.6.0');



thx

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [PrestaShop Theme Provider] PS version compliancy

Postby inveo » Wed Apr 29, 2015 9:58 am

Are you overriding Module.php file? (is there override/classes/module/Module.php file on your FTP?)

PM us either classes/module/Module.php or override/classes/module/Module.php file (if exists). There is likely a bug in this file since the PrestaShop Theme Provider module was tested across PS 1.3 - 1.6 versions and for 1.5.6.0 worked fine.

inveo
Inveo Support
Posts: 1280
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [PrestaShop Theme Provider] PS version compliancy

Postby inveo » Fri May 01, 2015 9:19 am

The problem has been caused by a buggy PrestaShop code. An update of the PrestaShop Theme Provider module was released to address this issue.