[osCommerce] MSU adding weird Session ID number one time

Magic SEO URLs for CRE Loaded.
inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] MSU adding weird Session ID number one time

Postby inveo » Fri Aug 14, 2009 4:03 pm

All is done. It was a problem with incorrect calling tep_href_link() function as I expected. Many developers don't know how to use this function properly.
I left the original file on the ftp (www/catalog/includes/modules/product_listing-old.php) so you can compare both new and old files if you are interested what was changed (two tiny changes).

buskerdoo
Posts: 14
Joined: Fri Aug 14, 2009 1:33 pm

Re: [osCommerce] MSU adding weird Session ID number one time

Postby buskerdoo » Fri Aug 14, 2009 5:14 pm

Thanks. I will look at it.

It is still showing a osCsid the first time but now it is correctly formated so it goes to the page. Is it supposed to show the first time?

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] MSU adding weird Session ID number one time

Postby inveo » Sat Aug 15, 2009 12:15 am

Sessions IDs (osCsid parameter in URLs) are removed when one of 120 worldwide webcrawlers is detected. Also, if the webcrawler finds a backward link containing Session ID, it is redirected to the non-Session ID version of the URL.

buskerdoo
Posts: 14
Joined: Fri Aug 14, 2009 1:33 pm

Re: [osCommerce] MSU adding weird Session ID number one time

Postby buskerdoo » Thu Sep 03, 2009 9:56 am

So I'll come back and build on this thread.

Are you saying there is still a problem in:
tep_href_link() function

hence the incorrect session id and then it doens't get take off?

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] MSU adding weird Session ID number one time

Postby inveo » Thu Sep 03, 2009 9:59 am

Soe tep_href_link() function arguments used in your MODs are incorrect and therefore generated links are incorrect as well.

buskerdoo
Posts: 14
Joined: Fri Aug 14, 2009 1:33 pm

Re: [osCommerce] MSU adding weird Session ID number one time

Postby buskerdoo » Thu Sep 03, 2009 10:03 am

We didn't make any mods so I don't really know what to do here.

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] MSU adding weird Session ID number one time

Postby inveo » Thu Sep 03, 2009 10:47 am

If I remember correctly, you are using a modified code for categories, files are located in includes directory.

buskerdoo
Posts: 14
Joined: Fri Aug 14, 2009 1:33 pm

Re: [osCommerce] MSU adding weird Session ID number one time

Postby buskerdoo » Thu Sep 03, 2009 1:02 pm

My appolgies. You are correct. Too many projects going at one time.

So, will this change be similar to the one you made in product_listing.php?

Thanks for any and all help. I can't get ahold of my php programer this week so I'm making due with my limited skills.

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] MSU adding weird Session ID number one time

Postby inveo » Thu Sep 03, 2009 2:49 pm

buskerdoo wrote:So, will this change be similar to the one you made in product_listing.php


I think so.

buskerdoo
Posts: 14
Joined: Fri Aug 14, 2009 1:33 pm

Re: [osCommerce] MSU adding weird Session ID number one time

Postby buskerdoo » Thu Sep 03, 2009 2:54 pm

Found it and fixed it. Working perfect now.

And for anyone else reading this thread - it was definitly OUR programming problem and not MSU.

MSU is working perfectly and does exactly what it says it will.