[osCommerce] Fatal error with correct Zend en php version

Magic SEO URLs for CRE Loaded.
shotputty
Follower
Posts: 46
Joined: Tue May 11, 2010 3:28 pm

[osCommerce] Fatal error with correct Zend en php version

Postby shotputty » Tue Jun 15, 2010 10:19 am

I get this error:

Code: Select all

Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Optimizer expects 2 in /home/p*****/domains/mydomain.de/public_html/includes/magic_seo_url.php on line 0


PHP Version: 5.2.5 (Zend: 2.2.0)
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.2.8, Copyright (c) 1998-2007, by Zend Technologies

The error applies to the php version according to the manual. My php version seems to be fine. And my Zend Optimizer is above 3.0.

I purchased this license today to give you ftp access for another topic (static pages additions) but first I need it to work in this particular site.
What is wrong with this setup?

inveo
Inveo Support
Posts: 1276
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] Fatal error with correct Zend en php versio

Postby inveo » Tue Jun 15, 2010 10:30 am

Please make sure includes/magic_seo_url.php file has been uploaded in BINARY mode and is not corrupted. If this does not help, please update ZO to the latests version.

shotputty
Follower
Posts: 46
Joined: Tue May 11, 2010 3:28 pm

Re: [osCommerce] Fatal error with correct Zend en php versio

Postby shotputty » Tue Jun 15, 2010 12:03 pm

Binary was ok. I just upgraded from Zend 3.2x to 3.3.9 , that did make the difference, it now works. Strange I need such a high version. I will now PM you for that other issue with static pages! Thanks! 8-)