[osCommerce] Checkout procedure

Magic SEO URLs for CRE Loaded.
pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

[osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 4:55 am

Hi - having installed Magic SEO for OsCommerce i am finding that i can no longer go through the checkout procedure nor can i gain access to the "my account" section. It just keeps bouncing around looking for the page and then says page cannot be displayed. I know it is Magic SEO that is at fault because i have commented it out in application_top.php and it works fine. When i re enable it, it creates the same problem again. Need help !! URGENT PLEASE

Thanks - Phil

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] Checkout procedure

Postby inveo » Mon May 25, 2009 6:04 am

What is the exact error message or HTTP status code? Please post your web site URL.

pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

Re: [osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 6:10 am

Error is:

Safari can’t open the page.
Too many redirects occurred trying to open “http://www.teddybearmaker.co.uk/account/”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

The address is as above - thanks - Phil

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] Checkout procedure

Postby inveo » Mon May 25, 2009 6:13 am

It looks like your web server does not return the correct state of HTTP and HTTPS. I will need your FTP login details in order to correct this.

pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

Re: [osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 6:19 am

I have PM you with the details. Thanks

pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

Re: [osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 7:40 am

You should have received my FTP details now. I am never sure as to whether the PM has gone as it remains in my outbox. Not sure what is going on there??

Anyway they have been sent. Thanks Phil

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] Checkout procedure

Postby inveo » Mon May 25, 2009 1:44 pm

It was caused by incorrectly configured mod_negotiation loaded into Apache. I fixed by renaming some files and re-generating the .htaccess file content:

Code: Select all

account.php
includes/languages/english/account.php
specials.php
includes/languages/english/specials.php
reviews.php
includes/languages/english/reviews.php



Code: Select all

accountmsu.php
includes/languages/english/accountmsu.php
specialsmsu.php
includes/languages/english/specialsmsu.php
reviewsmsu.php
includes/languages/english/reviewsmsu.php

pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

Re: [osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 1:58 pm

Hi - That seemed to fix the checkout procedure but it still leaves a problem when clicking on the "my account" link at the top i get a 404 error.

Not Found

The requested URL /account.php was not found on this server.

Sorry to be a pain but its strange that it has started doing this, but to be honest i did not check all buttons when it was installed.

Thanks
Phil

inveo
Inveo Support
Posts: 1281
Joined: Sat Feb 02, 2008 12:07 pm
Contact:

Re: [osCommerce] Checkout procedure

Postby inveo » Mon May 25, 2009 2:00 pm

pgreen50 wrote:Hi - That seemed to fix the checkout procedure but it still leaves a problem when clicking on the "my account" link at the top i get a 404 error.

Not Found

The requested URL /account.php was not found on this server.


You simply only need to fix the link, please see my post above.

pgreen50
Posts: 21
Joined: Fri May 22, 2009 6:48 am

Re: [osCommerce] Checkout procedure

Postby pgreen50 » Mon May 25, 2009 2:13 pm

Sorry i can see that you posted the above but im lost as to what you are actually saying. Do i need to edit those php files.