[osCommerce] non-static page workaround not working

Custom URLs and redirections.
shotputty
Follower
Posts: 46
Joined: Tue May 11, 2010 3:28 pm

[osCommerce] non-static page workaround not working

Postby shotputty » Mon Sep 13, 2010 7:21 am

Hi, I've made a mod for static OScommerce pages which works like a charm: http://www.magic-seo-url.com/board/custom-rewrite-rules-for-oscommerce-50.html

No I've made a copy of the shopping_cart.php only with a little different layout and some other name. When I go to this page, for which I've made my static page adjustments, it looks good up until you change a quantity in your "cart".

Here's my rule in .htaccass: RewriteRule ^([a-z]{2})/order-form$ bestelformulier.php?language=$1 [L,QSA]

I've noticed it doesn't work because when you update a quantity it gives you this:

domain.com/order_form?action=update_product
So basically the "?action=update_product" makes the SEO link fail. Can I solve this with an extra or adjusted rewrite rule ?
Magic SEO URLs for osCommerce

shotputty
Follower
Posts: 46
Joined: Tue May 11, 2010 3:28 pm

Re: [osCommerce] non-static page workaround not working

Postby shotputty » Tue Nov 16, 2010 7:10 am

Hi there, it's me again. I've aming for yet another license of your very cool product. MSU is working great for me for 3 websites now. For the 4th, I need this workaround for non-static pages to function properly.

Let me explain my issue, I have made copies of the reviews pages which are standard in OScommerce. I've reprogrammed them so they do not contain reviews but questions. In short, it is the same functionality but then with questions instead of reviews.

How can I make MSU perform its magic on these pages (they are dynamic, not static)? If I can make thát work, only then will it be worthwhile to get a license for this new site. These questions pages will be an important SEO factor for the entire website.

------------

edit:

I just copied the entire reviews section in the .htaccess file and renamed every part that says 'reviews' to 'questions'. This makes pretty URL's work but not redirect. I'm going to make some modifications in my tep_href, see if I can work something out...

-----------

edit 2:
I think I figured it out. Will post some guide soon.


Return to “Custom Rewrite Rules”

Who is online

Users browsing this forum: No registered users and 0 guests